Personal Edition Workstation FAQ (Updated for v.13)

What versions of Workstation Personal Edition are supported?

ClearCanvas Workstation Personal Edition version 13. All supporting activities for prior versions of Workstation Personal Edition has been discontinued. For more information, see the Communication Notice.

Why does the application I previously integrated with Personal Edition 7.x no longer work with Personal Edition 13.0?

If you previously leveraged the automation functionality to launch Personal Edition from another application, you will need to make some small changes to the calling application so that it works properly with Personal Edition 13.0.  In particular, you will need to change the URLs of certain service endpoints as follows:

v.7.x (OLD)v.13 (NEW)
Automation:
http://localhost:51124/ClearCanvas/
ImageViewer/Automation
or
net.pipe://localhost/ClearCanvas/
ImageViewer/Automation
Automation:
http://localhost:51124/ClearCanvas/
WorkstationClinical/Automation
or
net.pipe://localhost/ClearCanvas/
WorkstationClinical/Automation
StudyLocator:
http://localhost:51124/ClearCanvas/
ImageViewer/StudyLocator
or
net.pipe://localhost/ClearCanvas/
ImageViewer/StudyLocator
StudyLocator:
http://localhost:51124/ClearCanvas/
WorkstationClinical/StudyLocator
or
net.pipe://localhost/ClearCanvas/
WorkstationClinical/StudyLocator

Note that the URL of the StudyLocator2 endpoint has not changed.

Why can’t my application connect to the automation service unless I “Run as Administrator”?

ClearCanvas Workstation needs to host a web service internally in order for automation to work; however, by default, Windows restricts the ability to host web services to administrative users only. To allow any user to host the automation services:

  1. Download the HttpNamespaceManager utility from http://blogs.msdn.com/b/paulwh/archive/2007/05/04/addressaccessdeniedexception-http-could-not-register-url-http-8080.aspx
  2. Launch the utility and add the following URLs to its list:
    • http://+:51124/ClearCanvas/WorkstationClinical/Automation
    • http://+:51124/ClearCanvas/WorkstationClinical/StudyLocator
    • http://+:51124/ClearCanvas/ImageViewer/StudyLocator2
  3. When prompted for a user account, type “Everyone”
What is the password to login?
 
ClearCanvas Workstation requires you to re-authenticate yourself using the same Windows username and password of the account on which you are running the Workstation. For example, if you normally log in to Windows using the account jsmith, then you would need to enter the password to the jsmith account into the ClearCanvas Workstation login screen. Your password is used immediately to authenticate against Windows, and is not stored or transmitted by the Workstation.
 
Why can’t I retrieve studies from the server?
 
Although you may be able to verify and query a remote server for a list of studies, it does not ensure that the server is able to send studies to your Workstation. This can be due to a number of reasons including your own firewall blocking the server from sending files to your computer, the server trying to send to the wrong port, or a routing issue on your network. This can also be caused by a database failure where the Workstation is unable to use SQL Server CE to access the database due to a version mismatch. See "I am unable to query server: My Studies." question below for details.
 
I am unable to query server: My Studies.
 
This is caused by a mismatch of the SQL Server Compact Edition version installed on the system and the version ClearCanvas Workstation is trying to use. Download and install the latest versions of both the 32-bit and 64-bit versions of SQL Server CE from Microsoft to resolve this issue.
 
Where is the Write to Media button?
 
As writing to media can only be done when your Workstation is in possession of the image files, you must select My Studies in the study browser for the Write To Media button to appear. If the study you wish to burn is not stored locally, you must retrieve it first from a remote server. Although the button was previously visible but disabled when a remote server was selected, it has now been removed completely when it is not possible to use it. 
 
I get a C++ error.
 
This is caused by a mismatch of the Visual Studio C++ redistributable version installed on the system and the version the ClearCanvas Workstation is trying to use. On a 64-bit system, you must install the 64-bit version.
 
Why have my studies disappeared?
 
When your computer is running low on disk space, the Workstation will automatically try to remove studies from the filestore in order to recover space. Deletion is triggered when disk capacity exceeds the high watermark threshold, if your studies disappear soon after you retrieve or import them, it is likely that you are already above highwater. You can configure the watermarks in the Diskspace Manager settings.
 
Can I change the text overlay?
 
The ClearCanvas Workstation software does not provide a means to change the overlay text displayed over an image, however, you have the option to hide the overlay in the toolbar.
 
I am unable to stream images.
 
Steaming is only possible when communicating with a ClearCanvas ImageServer. Check your firewall on the server to ensure that the necessary streaming ports are open.
 
My plugin from 2.0 doesn’t work.
 
You will need to take the plugin source and modify it to work with the new 7.0 version libraries. Note that installing the plugin in an official 7.0 release will make that installation uncertified. Alternatively, you can build the entire Workstation from source and distribute it together with your plugin. See the Developers page for details on how to get the source code.
 
How can I change the Patient information?
 
You can change the patient information for a single image by using the DICOM editor. Note that you should not use the Anonymization Tool to edit patient information as it will delete other information in the header.
 
Will I lose my studies if I upgrade? 
 
During the upgrade, even though the old version of Workstation will be removed, it does not remove the studies on your local filestore. Once the new version is installed it will try to automatically reindex your local filestore to make your studies accessible again. If you had a custom filestore path, you will have to manually specify the path again before attempting to reindex.
 
How can I import a study into the workstation?
 
In the study browser screen, select the My Computer tab and navigate to the images on your computer. Right click on them to import.
 
When I try to Import studies it fails
 
You cannot import an image that is already in the filestore directory. Move the images out of the filestore and try again. If the service is not running, you will need to restart it before importing again.
 
When I import, my studies disappear
 
When your computer is running low on disk space, the Workstation will automatically try to remove studies from the filestore in order to recover space. Deletion is triggered when disk capacity exceeds the high watermark threshold, if your studies disappear soon after you retrieve or import them, it is likely that you are already above highwater. You can configure the watermarks in the Diskspace Manager settings.
 
Association rejected
 
This can result from incorrect AE Title and/or port specified for the device you are trying to communicate with. It can also happen when trying to retrieve or send an image that is not supported by the destination device. For more information on the cause, you can check the application log file which can be accessed from the Help menu.
 
How do I edit DICOM tags?
 
There is a DICOM editor tool which is available to edit specific tags in a single image. Note that you will have to save your changes to the DICOM file, overwriting the existing file, and then reindex your filestore to see the changes in the Workstation.
 
How can I export a study?
 
Studies can be exported as JPEG, PNG, or other common image files by using the clipboard. You can even choose the format, Field of view, scale and background colour.
 
Why are the operation buttons greyed out?
 
When the file operation buttons such as Retrieve, Send, Write to Media are disabled, it means that the software is unable to execute these operations on your local files because the services are not running. Start the ClearCanvas Workstation service from the Tools menu in order to proceed.
 
Why can’t I start my services?
 
If you are unable to start the service, it is likely that the port is already in use by another program. You can select a different DICOM listening port for Workstation and try starting them again. You may also be unable to start the services if your Windows User Account is does not have administrative privileges.
 
How to compare two studies side by side?
 
Each tab in the Workspace can be dragged to a docking position. If you open up two studies in separate tabs, you can then drag one of the tabs to dock beside the other in order to view them side by side.
 
Can the ClearCanvas Workstation work with my PACS?
 
When communicating with other DICOM devices, ClearCanvas Workstation conforms with the DICOM standard in order to maximize compatibility with other DICOM devices. Provided that your PACS supports typical DICOM communications and allows it with other devices, it will be able to communicate with ClearCanvas Workstation. See the respective device's DICOM conformance statement for details on supported DICOM functions.
 
Why is the cine so choppy?
 
Without sufficient available RAM, the Workstation will try to remove images which are not being viewed from memory in order to make room for other images which are being actively viewed. When using the Cine tool, this can cause your computer to repeatedly load and unload images from memory, impacting the ability of your computer to perform the Cine function smoothly. Try closing some applications to free up more RAM, or upgrade your computer with additional RAM.
 
I can’t retrieve from a server over the internet?
 
In order for a remote DICOM device such as a PACS or other viewer to send images to you, it must be able to reach your computer by having the data correctly routed across different networks and through firewalls. The mostly likely reason preventing you from retrieving a study over the internet is that traffic from outside your private network is not routed inside to your computer so the remote device is unable to reach you. Also check that all the firewalls between the remote device and your computer are allowing traffic through.
 
Why does it say my license key is associated with a different computer?
 
There are a few reasons why you may encounter this, but essentially, your key is either in use on another computer, or you have changed the hardware on your computer. You have the option to reassociate the license key with your computer within the license agreement terms, but if you suspect your key is being used by an unauthorized party, you can contact us to have the key revoked and a new key issued for you. 
 
How can I query other servers for priors?
 
After adding the remote device in your Servers list, you can automatically query it for priors when opening a study by configuring it as a Default Server in the Options screen.
 
My Workstation says "This installation has been modified"?
 
ClearCanvas Workstation provides an anti-tampering feature that will notify the user if the installation differs in any way from its intended configuration. Because we rigorously test our software in a certain known configuration, changes to the software mean we can no longer certify that the software will function as intended. For example, if a new plugin is added or an existing one replaced, the software could function incorrectly and any certifications the software carries with it would be rendered null and void. If the software has been tampered with, you will see a warning in red stating "Warning: This installation has been modified" on the Splash, Login and About screens.
 
How do I remove the text overlay?
 
The text overlay, with the exception of the Lossy Compression indicator, can be toggled on and off by clicking the Show/Hide Overlays button on the toolbar, and then checking or unchecking the Text Overlay item on the resultant drop down menu. Alternatively, you may check or uncheck the Tools > Standard > Show/Hide Text Overlay menu item.
 
Log shows "Exception thrown by target of invocation."
 
This message in the log indicates that the Workstation was trying to communicate with another software component that experienced an error and reported back to the Workstation as such. It is a often a benign message and you may continue using the Workstation.
 
A patients study will not open.
 
The study may not be in a supported format. If you are using Image Streaming, make sure the device you are streaming from is indeed a ClearCanvas ImageServer. Also check that the server's firewall is not blocking the streaming ports so that your streaming request is accepted.
 
"No Valid presentation context."
 
This results when you are working with a study that is either using an unsupported type of compression or contains an unsupported type of image.
 
Printing doesn’t work.
 
You need to have a DICOM-compliant film printer configured in order to print. If the print job produces an error, ensure that you have sufficient system memory for printing large jobs.
 
Images are sometimes blank when I scroll quickly.
 
This can happen when there is insufficient available RAM to load the entire study at once, particularly when streaming. This causes the software to load out images to make room for new ones but when scrolling too quickly, you can sometimes catch a blank view box before there was enough room freed up to load in an image.
 
Why does it say "LOSSY" in yellow when I view images?  
 
Lossy compressed images displayed by the software will show the text "LOSSY" in yellow on the text overlay, along with the compression ratio(s). Images can be lossy compressed generally for one of two reasons:
 
1. The modality that originally created them stored them in a lossy compressed format. 
In this situation, whether or not the images are appropriate for diagnosis is dependent on the intended use of the modality and the images it produces.
 
2. The images have been lossy compressed by a storage device, such as a PACS system. 
Such images should never be used for diagnosis, but rather the original images should be used. This includes images that were originally lossy compressed, and have been compressed further by a storage device. This will be evident on the image text overlay, as there will be multiple compression ratios displayed.
 
My Workstation closes on startup.
 
If you receive and error immediately on launching the workstation, it may be necessary to clear out your user cache, which may be corrupt. You can do this by deleting the user.config file
 
"No writable device found."
 
Your computer may not have hardware that is capable of writing to media. For example, if you have a basic CD-ROM drive, it cannot be used to write CDs. You will need to have a CD, DVD, or Blu-Ray (or combo) writer installed in your computer in order for the media writing feature in ClearCanvas to function.
 
DICOM overlays are not appearing.
 
The Workstation supports overlays which are stored in the DICOM header. The modality or viewer which produced the overlays may not be storing them in a compatible fashion. You can try configuring the source device to store them as DICOM overlays in the 6000 series tags in the header in order for them to be visible on the Workstation
 
How do I delete attachments?
 
Attachments exist as a separate series in a study. If you are working with Workstation,  you can delete the series from your filestore and reindex. If you are trying to delete an attachment from a study on a remote device, the delete must be done on that device.
 
Why do my images appear all white or washed out?
 
When the image is missing a LUT, the software will try to guess what the expected Window/Level values are. Sometimes the guess is too far off and the image appears all white. You can manually adjust the image with the mouse or you can try applying presets.
 
How can I move the filestore to a different location?
 
The Shredhost application config file specifies the location of the filestore. The default filestore path is ".\filestore" but you can change it to something like "D:\filestore" or another path of your choosing. You must restart the service for the change to take effect.
 
How can I save my measurements and annotations?
 
The Workstation can save image markups in a DICOM compliant format using Key Object Documents (KO in DICOM) and Softcopy Presentation States (PR in DICOM). You can create Key Images which will save your markups.
 
How do I retrieve by series?
 
In the study browser, select the study and click on View Series Details. On this new screen you can retrieve individual series.
 
Why can’t I attach a PDF to a study on a server?
 
The PDF cannot be attached to a study on a remote server if it is not a ClearCanvas streaming server. In order to attach the PDF in this case, you will need to retrieve the study to your local filestore, attach it there, and then send the study back to the server. You can set your Publishing configuration to automatically send back to the source server after attaching a PDF to a local study.
 
How do I show key images using my Hanging Protocols?
 
Key Images cannot be captured in the Hanging Protocol layouts, but they will appear in the Residual layout at the end of the layout selection. You need to enable residual layouts in the Hanging Protocol options in order to see them.
 
How do I show PET/CT Fusion images in Hanging Protocols?
 
Fused PET/CT images are not supported in Hanging Protocols because these images are generated in real time. 
 
I can’t perform MPR on a series?
 
The MPR viewer only supports loading MPR on three or more images and they must have the same orientation, frame of reference and slice spacing. It is possible that you are missing slices, or they are uneven, or you are trying to use a multiframe image which are not supported. Gantry tilted images can only be used if the tilt is vertical.
 
What does 'Calibration Unknown' mean?
 
Pixel size information stored in the image headers are used by the Workstation to support features like ROI measurements and true size printing. The values may represent either the physical size of detector elements, or the anatomical size after some form of correction (either by assuming the anatomy of interest is at a particular depth, or by using fiducials located at the same depth as the anatomy of interest). When the calibration method cannot be determined, the text overlay will report that the calibration method is unknown. Discretion is advised when making measurements on such images.
 
Why are my measuremets in pixels?
 
The image does not provide pixel spacing information so the distance across pixels cannot be calculated. You can calibrate the image yourself using the Ruler Tool. 
 
What is FoR MISMATCH?
 
The FoR MISMATCH warning indicates that the Fusion images you are currently viewing are generated from two different series with different frames of reference. This means that the image data is not guaranteed to be registered properly, and that you should take care to verify that the Fusion images are valid. We allow Fusion between images with different frames of reference because some older PET-CT setups have separate PET and CT hardware, and the frames of reference recorded by the machines are not always unified, despite the machines being manually calibrated to be coincident.
 
Why can’t I send studies?
 
Is the Send Study button disabled? If so, the Workstation Shred Host Service is likely not running and will need to be restarted. Otherwise, check the Send/Receive Activity Monitor or the log file for an error message. Often, these error messages are descriptive enough to solve the problem.
 
If the study contains one or more very large files (on the order of hundreds of megabytes), you may run out of memory while sending the study. This is a known issue and will be fixed in a future version of the Workstation. As a temporary workaround, these very large files will need to be transferred manually by physical storage media, such as a USB flash drive. Alternatively, if possible, you can try to configure the modality such that it generates single frame instances rather than a single large multiframe image (which is usually the case with such large files).
 
Windows feature Pack for Storage is not installed.
 
If you have Windows XP or Windows Server 2003, you will need to install the Windows Feature Pack for Storage in order to use the media burning feature in ClearCanvas.
 
Why can't ClearCanvas Workstation write to my non-blank re-writable media?
 
In the interest of mitigating the risk of accidentally distributing unintended patient information, the Media Writer will only write to totally blank media even if it is re-writable. Non-blank re-writeable media must be erased with an external application prior to being used by the Media Writer.