Do you have a question?

First Name:
Surname:
Email:
Phone:
Message:
Get Audio Code

Can't build ImageServer
Last Post 29 Oct 2012 09:43 AM by Steve Wranovsky. 6 Replies.
Printer Friendly
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages Not Resolved
Ted TimarUser is Offline
New Member
New Member
Posts:9

--
19 Oct 2012 04:40 PM  

After several years, I decided to test a newer version of ImageServer.

I downloaded a bundle, did a pull and update.  Then I attempted to build.

For reference, I'm building with VS2010 on Win7 x64.

I received the following error:

F:\Xian\ImageServer\Services\Dicom\BaseScp.cs(37,27): error CS0535: 'ClearCanvas.ImageServer.Services.Dicom.BaseScp' does not implement interface member 'ClearCanvas.Dicom.Network.Scp.IDicomScp.Cleanup()'

There are further errors after that, but I'm guessing that they are consequences of the same problem.

My current revision is apparently 11448 (f80040ccbcbd), however, since I'm not an expert at mercurial, I've never looked for a global changeset id before, so if this doesn't look right, let me know.

Regards,

Ted

 

Steve WranovskyUser is Offline
Veteran Member
Veteran Member
Posts:2107

--
20 Oct 2012 05:35 PM  
Ted,

The current Default branch won't build of the ImageServer. We made an update during a Workstation release that broke the ImageServer, and just never cleaned it up in the Default branch. We just released a new version of the ImageServer off of the Yen branch. This should be merged into the default soon, or you could just build off of the Yen branch to get our latest code.

Steve
Ted TimarUser is Offline
New Member
New Member
Posts:9

--
22 Oct 2012 10:37 AM  
Thanks. Yen built. The Web Application didn't build, but I don't need it.
Jb HUser is Offline
New Member
New Member
Posts:3

--
26 Oct 2012 03:38 AM  
building with VS2010 on Win7 x64, but can not build Imageserver Web Application
Jb HUser is Offline
New Member
New Member
Posts:3

--
26 Oct 2012 03:39 AM  
building with VS2010 on Win7 x64, but can not build Imageserver Web Application
Jb HUser is Offline
New Member
New Member
Posts:3

--
26 Oct 2012 03:39 AM  
building with VS2010 on Win7 x64, but can not build Imageserver Web Application
Steve WranovskyUser is Offline
Veteran Member
Veteran Member
Posts:2107

--
29 Oct 2012 09:43 AM  
Can you give some more information?
You are not authorized to post a reply.

Active Forums 4.1