Do you have a question?

First Name:
Surname:
Email:
Phone:
Message:
Get Audio Code

Preview pain
Last Post 27 Jun 2012 02:01 PM by Rob L. 2 Replies.
Printer Friendly
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Rob LUser is Offline
New Member
New Member
Posts:18

--
27 Jun 2012 11:50 AM  

I'm a little mystified about the preview pane and its underlying web content.  I know that the client locates the web content using the BaseUrl setting in ClearCanvas.Ris.Client.WebResourceSettings.  However, I'm seeing some strange and inexplicable behavior.

Even when I shut down my web server (via the IIS control panel) and rename the RIS\web folder on disk, my client still loads the preview pages!  Even after rebooting.  Stepping into the code, an example URL is http://localhost/RIS/preview/performing.htm.  I've configured IIS to point the RIS virtual directory to a non-existent folder (renamed the folder after pointing IIS there).  Attempting to load that page in chrome manually verifies that it's not available.  Where is it getting the document from?  I see it go in here: _webBrowser.Navigate(_component.HtmlPageUrl); and it comes out with a valid document, but from where it came, I can't fathom.

I came to this observation while trying to figure out why the client running on my dev box shows the preview pane, while the client running on a test machine (with its BaseUrl pointed at the server's URL) does not.  Obviously, my attempts to isolate the problem have run into a wall.  Help?

- Rob

 

 

jonathanUser is Offline
Advanced Member
Advanced Member
Posts:997

--
27 Jun 2012 01:43 PM  
The only thing I can suggest is to clear the IE cache. Sometimes things seem to hang around in there.
Rob LUser is Offline
New Member
New Member
Posts:18

--
27 Jun 2012 02:01 PM  
That did the trick. Thanks Jonathan!

You are not authorized to post a reply.

Active Forums 4.1