Do you have a question?

First Name:
Surname:
Email:
Phone:
Message:
Get Audio Code

Exception in Image Server
Last Post 03 Jul 2012 12:13 AM by Steve Wranovsky. 1 Replies.
Printer Friendly
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Vittorio AUser is Offline
New Member
New Member
Posts:7

--
13 Jun 2012 04:25 PM  

I'm getting quite frequently the following exception in Image Server. It happens when multiple association are established from the same device. Is there a patch/workaround ? Thank you in advance!

Exception thrown    Unexpected User exception, description: Unexpected exception on OnReceiveAssociateAccept

System.NullReferenceException: Object reference not set to an instance of an object.     at ClearCanvas.ImageServer.Services.Dicom.MoveScpExtension.b__3(Object sender, AssociationParameters parms)     at ClearCanvas.Dicom.Network.Scu.ScuBase.OnReceiveAssociateAccept(DicomClient client, ClientAssociationParameters association)     at ClearCanvas.Dicom.Network.Scu.StorageScu.OnReceiveAssociateAccept(DicomClient client, ClientAssociationParameters association)     at ClearCanvas.Dicom.Network.DicomClient.OnReceiveAssociateAccept(AssociationParameters association)

Steve WranovskyUser is Offline
Veteran Member
Veteran Member
Posts:2107

--
03 Jul 2012 12:13 AM  
Looking at the code, it looks like the exception is happening when we're attempting to execute some code related to audit logging. The call stack would mean that the error occurs after a remove SCU send a Move Request to the IS, and the IS is opening an association to the Move Destination. As for why it might be happening, it looks a bit like it might be a case where the association is aborted or closed quickly due to there not being any images to actually send to the remote device. If there's any logging before or around when this occurs, it might offer some more clues as to what is happening. I think this is a new bug, so I don't think there's a workaround.

Steve
You are not authorized to post a reply.

Active Forums 4.1