Do you have a question?

First Name:
Surname:
Email:
Phone:
Message:
Get Audio Code

C-FIND and Private Tags
Last Post 14 May 2012 09:02 AM by Steve Wranovsky. 1 Replies.
Printer Friendly
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
David WUser is Offline
New Member
New Member
Posts:1

--
08 May 2012 11:29 AM  

While sending C-Find requests to the ImageServer from a new GE CT, the request fails with the following error:

Unexpected exception when processing FIND request.

ClearCanvas.Enterprise.Core.PersistenceException: Unexpected problem with select statment on table Study: Invalid tag:

00090010 ---> ClearCanvas.Dicom.DicomException: Invalid tag: 00090010

at ClearCanvas.Dicom.DicomAttributeCollection.get_Item(UInt32 tag)

at ClearCanvas.ImageServer.Services.Dicom.QueryScpExtension.PopulateStudy(IPersistenceContext read,

DicomMessageBase response, IEnumerable`1 tagList, Study row, String availability)

at

ClearCanvas.ImageServer.Services.Dicom.QueryScpExtension.<>c__DisplayClass11.b__9

(Study row)

at ClearCanvas.ImageServer.Enterprise.SqlServer2005.EntityBroker`3._Find(TSelectCriteria criteria, Nullable`1 startIndex,

Nullable`1 maxRows, SelectCallback`1 callback)

--- End of inner exception stack trace ---

at ClearCanvas.ImageServer.Enterprise.SqlServer2005.EntityBroker`3._Find(TSelectCriteria criteria, Nullable`1 startIndex,

Nullable`1 maxRows, SelectCallback`1 callback)

at ClearCanvas.ImageServer.Enterprise.SqlServer2005.EntityBroker`3.Find(TSelectCriteria criteria, SelectCallback`1

callback)

at ClearCanvas.ImageServer.Services.Dicom.QueryScpExtension.OnReceiveStudyLevelQuery(DicomServer server, Byte

presentationID, DicomMessage message)

I did verify that the CT is including the private tag 0009,0010 in the request.

Any work-arounds?

Steve WranovskyUser is Offline
Veteran Member
Veteran Member
Posts:2107

--
14 May 2012 09:02 AM  

 Hello,

This was caused by a bug in our software, which is reported here.  We've fixed this in our latest commercial versions of the software, but since we haven't been released in an open source version of the software yet.  I don't believe there's a workaround to the problem.

Steve

You are not authorized to post a reply.

Active Forums 4.1