Do you have a question?

First Name:
Surname:
Email:
Phone:
Message:
Get Audio Code

Import of DICOM files showing error
Last Post 20 Mar 2012 11:32 PM by stewart. 4 Replies.
Printer Friendly
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages Not Resolved
Supriya MUser is Offline
New Member
New Member
Posts:5

--
06 Mar 2012 01:28 PM  

When tried to import files from workstation I am getting below error. How to resolve this problem and import the files.

Failed to initiate an import of the selected items.: The server was unable to process the request due to an internal error. For more information about the error, either turn on Include ExceptionDetailInFaults(either from Service BehaviorAttribute or from the configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft.NET Framework 3.0 SDK documentation and instepect the server trace logs.

 

 

stewartUser is Offline
Veteran Member
Veteran Member
Posts:2359

--
08 Mar 2012 08:46 AM  
The real cause of this error will be in the application logs (from the Workstation, Help > Show Logs). What is the message at the tail of the log when this happens?
Supriya MUser is Offline
New Member
New Member
Posts:5

--
20 Mar 2012 02:04 PM  
2012-03-20 13:12:10,481 [1] WARN - Configuration store not found - defaulting to LocalFileSettingsProvider
2012-03-20 13:12:48,623 [23] ERROR - Exception thrown
System.ArgumentNullException: Value cannot be null.
Parameter name: No valid files have been specified to import.
at ClearCanvas.ImageViewer.Shreds.LocalDataStore.LocalDataStoreService.ImportProcessor.ValidateRequest(FileImportRequest request)
at ClearCanvas.ImageViewer.Shreds.LocalDataStore.LocalDataStoreService.ImportProcessor.Import(FileImportRequest request)
at ClearCanvas.ImageViewer.Shreds.LocalDataStore.LocalDataStoreServiceType.Import(FileImportRequest request)
2012-03-20 13:12:48,811 [1] ERROR - Exception thrown
System.ServiceModel.FaultException: The server was unable to process the request due to an internal error. For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework 3.0 SDK documentation and inspect the server trace logs.

Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at ClearCanvas.ImageViewer.Services.LocalDataStore.ILocalDataStoreService.Import(FileImportRequest request)
at ClearCanvas.ImageViewer.Services.LocalDataStore.LocalDataStoreServiceClient.Import(FileImportRequest request)
at ClearCanvas.ImageViewer.Services.Tools.DicomFileImportTool.Import()
2012-03-20 13:12:48,826 [1] WARN - Configuration store not found - defaulting to LocalFileSettingsProvider


This is error it displayed in ClearCanvas.Server.ShredHostService.log
Supriya MUser is Offline
New Member
New Member
Posts:5

--
20 Mar 2012 02:06 PM  
I tried to import files from the networkdrives then it displayed with above error message. But if I import files from the local hard drive then import without any problems.
stewartUser is Offline
Veteran Member
Veteran Member
Posts:2359

--
20 Mar 2012 11:32 PM  

 This is a known bug, which has been fixed in the commercial versions of the software. If you're working with the code, the most recent code should also work.

You are not authorized to post a reply.

Active Forums 4.1